Posted by on 10/25/2011
Problem:

Running your rails application you'll experience this error at the very start of your development.

Analysis:

This is usually due to version shifting. As of Rails version 2.3, the application.rb from the controller has been changed to application_controller.rb. Now if you run your application to a lower version of Rails, you'll surely encounter this error.

Solution:


The application.rb and application_controller.rb are just the same and all you need to do is to rename the file depending on your version.

No comments :

Post a Comment